VMware Postgres v10.15 Release Notes

This document describes features, fixes, and known issues in VMware Postgres v10.15.

Software Component Versions

VMware Postgres Version Component Component Version
10.15.0 PostgreSQL 10.15
pgBackRest 2.28
Patroni 1.6.5
psqlODBC 11.00-0000
pgjdbc 42.2.16
PL/Java 1.5.5
PL/R 8.4.1
PostGIS 2.5.5
Orafce 3.13.0

Release 10.15.0

Release Date: Jan 13th, 2021

PostgreSQL

  • VMware Postgres 10.15.0 updates the PostgreSQL database version to 10.15. Version 10.15 fixes three important issues:

    • CVE-2020-25695: Multiple features escape “security restricted operation” sandbox
    • CVE-2020-25694: Reconnection can downgrade connection security settings
    • CVE-2020-25696: psql’s \gset allows overwriting specially treated variables

    Version 10.15 also includes numerous bug fixes and improvements, as highlighted in Security Issues.

Known Issues and Limitations

  • You cannot install VMware Postgres alongside an existing Red Hat Enterprise Linux PostgreSQL installation.
  • VMware does not support using the deprecated XML2 module.
  • All software components in this release, including the client ODBC and JDBC drivers, are supported only on Red Hat Enterprise Linux (RHEL) version 7 and CentOS 7 systems.