Troubleshooting Common Problems

Installation Problems

PL/R Extension RPM Fails to Install

Problem

Installing the VMware Postgres PL/R extension RPM displays this message:

error: Failed dependencies:
    libR.so()(64bit) is needed by vmware-postgres-plr-extension-11.7-3.el7.x86_64

Resolution

R must be installed before you install the PL/R extension. Install R from the EPEL repo using these commands:

$ sudo yum install epel-release
$ sudo yum install R

After R has been installed, you can use yum to install the VMware Postgres PL/R extension RPM.

See Installing or Upgrading VMware Postgres for full installation procedures.

PostGIS Extension RPM Fails to Install

Problem

The PostGIS extension requires the gdal and gdal-devel libraries. However, if you try to install the gdal libraries before you install the Postgis extension, you will get file conflict messages for libgeos and libproj:

  file /usr/lib64/libgeos-3.4.2.so from install of vmware-postgres-postgis-extension-11.7-3.el7.x86_64 conflicts with file from package geos-3.4.2-2.el7.x86_64
  file /usr/lib64/libgeos_c.so.1 from install of vmware-postgres-postgis-extension-11.7-3.el7.x86_64 conflicts with file from package geos-3.4.2-2.el7.x86_64
  file /usr/lib64/libgeos_c.so.1.8.2 from install of vmware-postgres-postgis-extension-11.7-3.el7.x86_64 conflicts with file from package geos-3.4.2-2.el7.x86_64
  file /usr/bin/proj from install of vmware-postgres-postgis-extension-11.7-3.el7.x86_64 conflicts with file from package proj-4.8.0-4.el7.x86_64
  file /usr/lib64/libproj.so.0.7.0 from install of vmware-postgres-postgis-extension-11.7-3.el7.x86_64 conflicts with file from package proj-4.8.0-4.el7.x86_64

Resolution

Install the PostGIS extension first without dependencies using the rpm command:

$ sudo rpm -i --nodeps vmware-postgres-postgis-extension-<postgres-version>.<platform>.rpm

Then install the gdal and gdal-devel libraries from the EPEL repository:

$ sudo yum -i install epel-release
$ sudo yum -i install gdal gdal-devel